summaryrefslogtreecommitdiff
path: root/dev-vcs/rcs/rcs-5.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/rcs/rcs-5.10.0.ebuild')
-rw-r--r--dev-vcs/rcs/rcs-5.10.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.0.ebuild b/dev-vcs/rcs/rcs-5.10.0.ebuild
index 7195ab87aef1..5bd7347fc901 100644
--- a/dev-vcs/rcs/rcs-5.10.0.ebuild
+++ b/dev-vcs/rcs/rcs-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,14 @@ src_test() {
emake check
}
+src_test() {
+ # Tests attempt to call rcs commands on /dev/null and /tmp.
+ # https://bugs.gentoo.org/840173
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
src_install() {
emake DESTDIR="${D}" install