summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-4.0.1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index c0f76984ddee..5903cb3a6f62 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,4 +1,6 @@
AUX pre-commit-3.1.1-tests_git_file_transport.patch 1527 BLAKE2B 18d047f3b8a6fdc3da77aa5b8d9f60970ab5b69adc3790489ceffc17839a4cd21ed46428c5e2e98b50278b2c4dc49e35a09dd778000546828327ae96f910f95b SHA512 36cb194250dc0fefad2900452447ab590f678e6cd5edf07a7f072363733c263b7cb1167297c465a9372d4a38ab77a6c057046c66b872a958132a97d1a937d029
DIST pre-commit-3.8.0.gh.tar.gz 270925 BLAKE2B febb7b6bb2e43aec096e454b064b01b0973cd9d04b2d792a4ce7cef9df4f9c9c2e3bf1200f584e163c829c12ca17f57761375b297ab5c3d97dce569d5c219bdd SHA512 b6970ac00c5033938462675c20ea5e13c0439dc4f70cd627f11b22b0f87fb0a3590e9b3e9c677bfb66e4b3420f40de66ca7ccbc969847ee5fa8994532a558cd1
+DIST pre-commit-4.0.1.gh.tar.gz 286821 BLAKE2B 2d38ef4ad06744e11a75a9faddcf90f1fbb60f597d85782bf8065e90e746e62de0f7396ad09e3d03502208114ed75ed57f05ae143470b349a9b1dd6860ba72bd SHA512 93c01e4d64aa1010bdaac6e1774497fe38f757cc6b67b7546332c5fe3846583fc5ac71f70bb257e5bbe24062e060307b49abdcb539538ccedeb2cdf2243908a4
EBUILD pre-commit-3.8.0-r1.ebuild 2132 BLAKE2B 5bda58bacf4e98a4328db604a058e70399ed91ad4413f40a849149931eafd28005b5bf944aff4205ecda081e65b6ee5370faf5a9bebf88e3bcd45d13b9b28c74 SHA512 7ea6a4c5d5a21f485d8cf06269d7ef591b97771650c92be31cfb7388852020f461f7ce2d09af5d6465366e790de9dcb15f19ba74dd08b049243cae488b98d65e
+EBUILD pre-commit-4.0.1.ebuild 2134 BLAKE2B aea31c2c617e4cfa2f3f4b621b4128329cc88146148c25531963b6bf62f9caed64ca3629b94f92be459ae4cc47ae9f250d7786d3dca6f12a045f49576c5dfeee SHA512 4740b091fa3a851a7d6fd519d8e6d3bcc3ef0f4d56a51a616fe572324129c0469a27dbb8eac4e9548e6e014bb5f0be33f85b6e58f86458e07b9c459f29b00e92
MISC metadata.xml 391 BLAKE2B 08aea5db96326e51f252d2392f655100d2721dfa8eedfbb361221d92b0b0e0645152b8e1c2ccc11e8b50f24b59869fa2e1fc7dfaa42fdb23614ddbc963e9f102 SHA512 799e0df03afd4baef6296590b9133b45487d1e41f09e933a738367f0bcb3c6510ec8e26547b16ea5c07525d99b026ba1848d21e4001505c33a564b14746897c6
diff --git a/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild b/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild
new file mode 100644
index 000000000000..27a86ca9beb6
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL="ON"
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/
+ https://github.com/pre-commit/pre-commit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')
+"
+# coreutils requirement, see bug #885559
+BDEPEND="
+ sys-apps/coreutils[-multicall]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.1.1-tests_git_file_transport.patch" )
+
+EPYTEST_DESELECT=(
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and
+ # more) in order to run and while some of them do include
+ # "skip if not found" logic, most of them do not.
+ tests/languages/
+ tests/repository_test.py
+
+ # These three consistently fail with
+ # Calling "git rev-parse" fails with "fatal:
+ # not a git repository (or any of the parent directories): .git".
+ # including with the sandbox disabled.
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+
+ # These two fail if pre-commit is already installed (Bug #894502)
+ tests/commands/install_uninstall_test.py::test_environment_not_sourced
+ tests/commands/install_uninstall_test.py::test_installed_from_venv
+)
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )