summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest3
-rw-r--r--dev-vcs/pre-commit/metadata.xml12
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.1.ebuild56
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
new file mode 100644
index 000000000000..18483fecfa3f
--- /dev/null
+++ b/dev-vcs/pre-commit/Manifest
@@ -0,0 +1,3 @@
+DIST pre-commit-2.12.1.tar.gz 246313 BLAKE2B 45ee7c8217f88eeaa2e9eb11efd79291d6577134799b328f252bd4d4283c11754b36ffeedf045a5101c6edc8cdf330d566e404ae34f1a831a830e8e0346337e9 SHA512 6dbd804e1001276e6e8cea7c31b321a05798b38c59f37d5900317c3a9ceccf5103afcbdfd29f9438be3595a18ae15eb09dd222c91c439da47d7728a0e0a55c70
+EBUILD pre-commit-2.12.1.ebuild 1712 BLAKE2B 33a7360f824846898a5d4ee580b99ac1e274e6fe5cca49c94b99178313db0efbbce4b15250d8a83962e391d1ca8231f71b6c1373b0eb5702d17dd3105d59037a SHA512 e62620084bb56f228c0b5f50419324a504988d32def557e6c62a29da9c609430c02193cdd777c920738880ee2805c15d1497441c6d200d92f674d4b3bc89147a
+MISC metadata.xml 379 BLAKE2B 6224574b28f758241c6ad965ad59a423db76bd21c64c3577691104a8f45a4ee9b570f9cf1557f2ce17f00bf496b9eeb83741679dc0d6e1bb23c421f90fe9070f SHA512 f14032e386c2bb591390034086c7d4a2e8ce9aacc536574c517dff4691aa8c39bc966307ee91a5f76708f14601312fd16528a676e1918d82b2761185bc27df9f
diff --git a/dev-vcs/pre-commit/metadata.xml b/dev-vcs/pre-commit/metadata.xml
new file mode 100644
index 000000000000..cf8278c8169b
--- /dev/null
+++ b/dev-vcs/pre-commit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pre-commit/pre-commit</remote-id>
+ <remote-id type="pypi">pre-commit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
new file mode 100644
index 000000000000..5a4c4ea945f6
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-2.12.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: figure out why these tests - all of which invoke git - fail:
+# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall]
+# "Git failed", not much information beyond that
+# - tests/main_test.py::test_try_repo
+# Ditto
+# - tests/commands/install_uninstall_test.py::test_installed_from_venv
+# "git commit" returns 1 instead of 0, again no details
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/cfgv[${PYTHON_USEDEP}]
+ dev-python/identify[${PYTHON_USEDEP}]
+ dev-python/nodeenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+
+ # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
+ rm -rf tests/languages tests/repository_test.py
+}