summaryrefslogtreecommitdiff
path: root/dev-vcs/monotone/monotone-1.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/monotone/monotone-1.0-r4.ebuild')
-rw-r--r--dev-vcs/monotone/monotone-1.0-r4.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-vcs/monotone/monotone-1.0-r4.ebuild b/dev-vcs/monotone/monotone-1.0-r4.ebuild
index 16d77a02eb42..2b4a541b8a1a 100644
--- a/dev-vcs/monotone/monotone-1.0-r4.ebuild
+++ b/dev-vcs/monotone/monotone-1.0-r4.ebuild
@@ -7,7 +7,8 @@ inherit bash-completion-r1 elisp-common eutils toolchain-funcs user
DESCRIPTION="Monotone Distributed Version Control System"
HOMEPAGE="http://monotone.ca"
-SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.bz2"
+SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/${P}-gentoo-patchset.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
@@ -37,13 +38,13 @@ src_prepare() {
( $(gcc-major-version) -eq "3" && $(gcc-minor-version) -le 3 ) ]]; then
die 'requires >=gcc-3.4'
fi
- epatch "${FILESDIR}/monotone-1.0-bash-completion-tests.patch"
- epatch "${FILESDIR}/monotone-1.0-botan-1.10-v2.patch"
- epatch "${FILESDIR}/monotone-1.0-glibc-2.14-file-handle.patch"
- epatch "${FILESDIR}/monotone-1.0-boost-1.53.patch"
- epatch "${FILESDIR}/monotone-1.0-pcre3.patch"
- epatch "${FILESDIR}/monotone-1.0-texinfo-5.1.patch"
- epatch "${FILESDIR}/monotone-1.0-gcc6.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-bash-completion-tests.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-botan-1.10-v2.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-glibc-2.14-file-handle.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-boost-1.53.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-pcre3.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-texinfo-5.1.patch"
+ epatch "${WORKDIR}/${P}-gentoo-patchset/monotone-1.0-gcc6.patch"
}
src_configure() {