summaryrefslogtreecommitdiff
path: root/dev-vcs/mercurial/mercurial-5.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/mercurial/mercurial-5.8.1.ebuild')
-rw-r--r--dev-vcs/mercurial/mercurial-5.8.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-vcs/mercurial/mercurial-5.8.1.ebuild b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
index bed3532e284f..001bdb53dcb0 100644
--- a/dev-vcs/mercurial/mercurial-5.8.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -291,11 +291,13 @@ src_test() {
}
python_test() {
- local TEST_DIR
-
+ if [[ ${EPYTHON} == python3.10 ]]; then
+ einfo "Skipping tests for unsupported Python 3.10"
+ return
+ fi
distutils_install_for_testing
cd tests || die
- "${PYTHON}" run-tests.py \
+ PYTHONWARNINGS=ignore "${PYTHON}" run-tests.py \
--jobs $(makeopts_jobs) \
--timeout 0 \
|| die "Tests fail with ${EPYTHON}"