summaryrefslogtreecommitdiff
path: root/dev-vcs/git-pw
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/Manifest4
-rw-r--r--dev-vcs/git-pw/files/git-pw-2.0.0-version.patch11
-rw-r--r--dev-vcs/git-pw/git-pw-2.0.0.ebuild42
-rw-r--r--dev-vcs/git-pw/metadata.xml17
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
new file mode 100644
index 000000000000..3fe043e08608
--- /dev/null
+++ b/dev-vcs/git-pw/Manifest
@@ -0,0 +1,4 @@
+AUX git-pw-2.0.0-version.patch 278 BLAKE2B 8ff5fc1f4928449095b5b644a5d933ffac72feec36b47972ae9206416e75b2e8355defa1e15a4e3a75b4a6ed6b35c634b4ba9c93d2d1d1a0d1e35d5c9223465c SHA512 02ee7fd042f9ac2869da210c90a11a2d98c7d22d3c5f416aadd7bbb2d1faaf01a76ab12d575ad646a78979fe047c8e005af7cc7031012a9ce1b7d229db13f8f8
+DIST git-pw-2.0.0.tar.gz 32151 BLAKE2B f8ef04b31cb4457ac9bae333bae65deb7d17469cd25a3724a27201dab0c05f98151a5ec1066cb9d2de81d82360f4e46eaa59ebd08904dfa0d16106f589e17e4c SHA512 83ac4d56091bfe9b03733939fb3e4feab22ce4455eebe8508bc730705b69054a2f060cfb8a1ea469476d9519809a89116ff56210efe4cd76e50df5a5d40886fc
+EBUILD git-pw-2.0.0.ebuild 1013 BLAKE2B fa1c26120c84e82d9426ca31a6817cbd6034a02d27e8cf816b150a7b2e356c5dc252c0519c6611372713845479a8f3b6376e725e83d5393f9a0e26187a369910 SHA512 f7384c234dc3fe17a3111c5f09ecb9f0de5758c90f50f905c4a964fc8b3b42b86cd771f2ab7706c0981f1f3d728511634ac1cedcaa7f3fd904f6da82930311d6
+MISC metadata.xml 572 BLAKE2B e9bc2b6775ef17fe1a1975e40e374a9ee1b3f98e51e140acee6f3a9caae0eddad1aee41cd417f36847fccd75da5505ffed28daa0680e15177fea3e8c6255f88b SHA512 021c311570c06714ed3ee803e8139790205f57d8731796e43f83212c84ffe4cd3462f29cff53489255f0518f561da26adde8c13ee3858ff5738d923b0f2109ca
diff --git a/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch b/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
new file mode 100644
index 000000000000..92706506c697
--- /dev/null
+++ b/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
@@ -0,0 +1,11 @@
+diff --git a/PKG-INFO b/PKG-INFO
+new file mode 100644
+index 0000000..9748ce5
+--- /dev/null
++++ b/PKG-INFO
+@@ -0,0 +1,5 @@
++Metadata-Version: 2.1
++Name: git-pw
++Version: 2.0.0
++Summary: A tool for integrating Git with Patchwork
++Home-page: https://github.com/getpatchwork/git-pw
diff --git a/dev-vcs/git-pw/git-pw-2.0.0.ebuild b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
new file mode 100644
index 000000000000..8efc99b1623b
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-version.patch" )
+
+distutils_enable_tests pytest
diff --git a/dev-vcs/git-pw/metadata.xml b/dev-vcs/git-pw/metadata.xml
new file mode 100644
index 000000000000..2845f37880c9
--- /dev/null
+++ b/dev-vcs/git-pw/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ git-pw is a tool for integrating Git with Patchwork, the web-based patch
+ tracking system. It only supports Patchwork 2.0+ and REST API support
+ must be enabled on the server end.
+ </longdescription>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">getpatchwork/git-pw</remote-id>
+ </upstream>
+</pkgmetadata>