summaryrefslogtreecommitdiff
path: root/dev-vcs/git-lfs/git-lfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-lfs/git-lfs-9999.ebuild')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index f5a948c8f4fd..641f9c79a60b 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,14 @@ RDEPEND="dev-vcs/git"
RESTRICT+=" !test? ( test )"
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
src_compile() {
# Flags -w, -s: Omit debugging information to reduce binary size,
# see https://golang.org/cmd/link/.
@@ -41,7 +49,7 @@ src_compile() {
src_install() {
dobin git-lfs
- dodoc {CHANGELOG,CODE-OF-CONDUCT,CONTRIBUTING,README}.md
+ einstalldocs
use doc && doman docs/man/*.1
}