summaryrefslogtreecommitdiff
path: root/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild')
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild
new file mode 100644
index 000000000000..f51f33fa7528
--- /dev/null
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-single-r1
+
+DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
+HOMEPAGE="https://github.com/newren/git-filter-repo/"
+SRC_URI="
+ https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-vcs/git-2.24.0
+"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ bash t/run_tests || die
+}
+
+src_install() {
+ python_fix_shebang git-filter-repo
+ dobin git-filter-repo
+ doman Documentation/man1/git-filter-repo.1
+}