summaryrefslogtreecommitdiff
path: root/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild')
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
index bf12a2763a11..5519692b3750 100644
--- a/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.38.0-r1.ebuild
@@ -3,12 +3,13 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
HOMEPAGE="https://github.com/newren/git-filter-repo/"
SRC_URI="https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz"
+S="${S}/release"
LICENSE="MIT"
SLOT="0"
@@ -16,11 +17,11 @@ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
- ${PYTHON_DEPS}
>=dev-vcs/git-$(ver_cut 1-2)
"
-
-S="${S}/release"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
python_prepare_all() {
cat > PKG-INFO <<-EOF || die