summaryrefslogtreecommitdiff
path: root/dev-vcs/git-extras
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-extras')
-rw-r--r--dev-vcs/git-extras/Manifest4
-rw-r--r--dev-vcs/git-extras/files/git-extras-6.1.0-no-bash-completion-install.patch12
-rw-r--r--dev-vcs/git-extras/git-extras-6.1.0.ebuild55
-rw-r--r--dev-vcs/git-extras/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-vcs/git-extras/Manifest b/dev-vcs/git-extras/Manifest
new file mode 100644
index 000000000000..91e7029915b9
--- /dev/null
+++ b/dev-vcs/git-extras/Manifest
@@ -0,0 +1,4 @@
+AUX git-extras-6.1.0-no-bash-completion-install.patch 556 BLAKE2B 9fbf1516888da9c5952fdaedf28987bcf46e62c6dd1342f810c9150625a78198224855dd18b386076a4fd689418c05d61cc8f0c5c0f747fb96ac6209a4fb402f SHA512 70d25e577174238f5fce6a3810146358904493a7ec3963eef6be8780de7b62bcda7e2c542e8f02cf2dd229acfc7368b72dfd4aff668fbc4e841eb6754b2036f2
+DIST git-extras-6.1.0.tar.gz 153503 BLAKE2B 3450edecb3116e19ffcf918b118aee04f025c06d812e29e8701f35a3c466b13d2578d41c8e1ee93327743d0019bf98bb3f397189e19435f89e3a259ff1b82747 SHA512 098415339177f802299d93947e2979a2fc6c2935eb2d735cd71ad76e035d5489e4c8d9009e2673c109b28e393319745be249cc195814087d59b436f4a56dabab
+EBUILD git-extras-6.1.0.ebuild 1160 BLAKE2B 85d0d2077e00e01276b55f5ed70f9cff1d69546abcb93678e3f92e188190871058c75ec80594cbea5acf34bb972b7f3f2206b29863032ac01ffe88b7283bd822 SHA512 656f125a60213ac1d9e1477753fd110e5d78b3dd6e6852ae347114acf8b0518179105e5f46e2c71fe05b122d2e11e825aae38781ffd19f5fd07c1d016119df6b
+MISC metadata.xml 317 BLAKE2B 81e94ccb8505cef2f0dd08b3cfa09c0f00f8ec7ba52f507cdb85467d48d10d7edf311beddb8f766fbcf10a49f62245839dda84a194268a0a5fdfb66ace18015e SHA512 b9353731d4665fe680aed7ffd9236177651ce2bbf6a7210652055cacf5fea38ee5fb7caecaa7cdeefcd7068fdfac85a1fa504135eccc6dda56929a5c1c2dde1b
diff --git a/dev-vcs/git-extras/files/git-extras-6.1.0-no-bash-completion-install.patch b/dev-vcs/git-extras/files/git-extras-6.1.0-no-bash-completion-install.patch
new file mode 100644
index 000000000000..c1d606c3a38c
--- /dev/null
+++ b/dev-vcs/git-extras/files/git-extras-6.1.0-no-bash-completion-install.patch
@@ -0,0 +1,12 @@
+We shouldn't install this manually via the Makefile - or to that location.
+--- a/Makefile
++++ b/Makefile
+@@ -69,8 +69,6 @@ install: check
+ cp -f man/git-*.1 $(DESTDIR)$(MANPREFIX); \
+ echo "cp -f man/git-*.1 $(DESTDIR)$(MANPREFIX)"; \
+ fi
+- @mkdir -p $(DESTDIR)$(SYSCONFDIR)/bash_completion.d
+- cp -f etc/bash_completion.sh $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/git-extras
+ @echo ""
+ @echo "If you are a zsh user, you may want to 'source $(CODE_DIR)etc/git-extras-completion.zsh'" \
+ "and put this line into ~/.zshrc to enable zsh completion"
diff --git a/dev-vcs/git-extras/git-extras-6.1.0.ebuild b/dev-vcs/git-extras/git-extras-6.1.0.ebuild
new file mode 100644
index 000000000000..7ee7468ae07c
--- /dev/null
+++ b/dev-vcs/git-extras/git-extras-6.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Git utilities -- repo summary, repl, changelog population, author commit percentages and more"
+HOMEPAGE="https://github.com/tj/git-extras"
+SRC_URI="https://github.com/tj/git-extras/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos"
+
+RDEPEND="
+ app-shells/bash
+ dev-vcs/git
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.0-no-bash-completion-install.patch
+)
+
+src_prepare() {
+ default
+
+ # For now, don't force including the git completion
+ # sed -i -e "1 i source $(get_bashcompdir)\/git" etc/bash_completion.sh || die
+}
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc" \
+ install
+
+ # TODO: Unfortunately, none of the completion seems to
+ # actually work for me yet(?)
+
+ #newbashcomp "${S}"/etc/bash_completion.sh ${PN}
+
+ #insinto /usr/share/zsh/site-functions
+ #newins "${S}"/etc/${PN}-completion.zsh _${PN}
+
+ #insinto /usr/share/fish/vendor_completions.d
+ #doins "${S}"/etc/${PN}.fish
+}
diff --git a/dev-vcs/git-extras/metadata.xml b/dev-vcs/git-extras/metadata.xml
new file mode 100644
index 000000000000..a74e708790bf
--- /dev/null
+++ b/dev-vcs/git-extras/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tj/git-extras</remote-id>
+ </upstream>
+</pkgmetadata>