summaryrefslogtreecommitdiff
path: root/dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild')
-rw-r--r--dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild325
1 files changed, 325 insertions, 0 deletions
diff --git a/dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild b/dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild
new file mode 100644
index 000000000000..0bd8dd9fe5ba
--- /dev/null
+++ b/dev-vcs/git-credential-manager/git-credential-manager-2.5.0.ebuild
@@ -0,0 +1,325 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=8.0
+NUGETS="
+avalonia.angle.windows.natives@2.1.0.2023020321
+avalonia.buildservices@0.0.29
+avalonia.controls.colorpicker@11.0.10
+avalonia.controls.datagrid@11.0.10
+avalonia.desktop@11.0.10
+avalonia.diagnostics@11.0.10
+avalonia.freedesktop@11.0.10
+avalonia.native@11.0.10
+avalonia.remote.protocol@11.0.10
+avalonia.skia@11.0.10
+avalonia.themes.fluent@11.0.10
+avalonia.themes.simple@11.0.10
+avalonia.win32@11.0.10
+avalonia.x11@11.0.10
+avalonia@11.0.10
+castle.core@4.3.1
+coverlet.collector@3.1.0
+dotnet-xunit@2.3.1
+harfbuzzsharp.nativeassets.linux@7.3.0
+harfbuzzsharp.nativeassets.macos@7.3.0
+harfbuzzsharp.nativeassets.webassembly@7.3.0
+harfbuzzsharp.nativeassets.win32@7.3.0
+harfbuzzsharp@7.3.0
+libuv@1.9.0
+microcom.runtime@0.11.0
+microsoft.codeanalysis.analyzers@1.1.0
+microsoft.codeanalysis.analyzers@3.0.0
+microsoft.codeanalysis.common@1.3.0
+microsoft.codeanalysis.common@3.8.0
+microsoft.codeanalysis.csharp.scripting@3.8.0
+microsoft.codeanalysis.csharp@1.3.0
+microsoft.codeanalysis.csharp@3.8.0
+microsoft.codeanalysis.scripting.common@3.8.0
+microsoft.codeanalysis.visualbasic@1.3.0
+microsoft.codecoverage@17.1.0
+microsoft.csharp@4.0.1
+microsoft.csharp@4.3.0
+microsoft.identity.client.extensions.msal@4.60.3
+microsoft.identity.client@4.60.3
+microsoft.identitymodel.abstractions@6.35.0
+microsoft.net.test.sdk@17.1.0
+microsoft.netcore.app@1.0.0
+microsoft.netcore.dotnethost@1.0.1
+microsoft.netcore.dotnethostpolicy@1.0.1
+microsoft.netcore.dotnethostresolver@1.0.1
+microsoft.netcore.jit@1.0.2
+microsoft.netcore.platforms@1.0.1
+microsoft.netcore.platforms@1.1.0
+microsoft.netcore.platforms@2.1.2
+microsoft.netcore.runtime.coreclr@1.0.2
+microsoft.netcore.targets@1.0.1
+microsoft.netcore.targets@1.1.0
+microsoft.netcore.windows.apisets@1.0.1
+microsoft.testplatform.objectmodel@17.1.0
+microsoft.testplatform.testhost@17.1.0
+microsoft.visualbasic@10.0.1
+microsoft.win32.primitives@4.0.1
+microsoft.win32.primitives@4.3.0
+microsoft.win32.registry@4.0.0
+moq@4.10.1
+netstandard.library@1.6.0
+netstandard.library@1.6.1
+newtonsoft.json@9.0.1
+nuget.frameworks@5.11.0
+reportgenerator@5.1.9
+runtime.any.system.collections@4.3.0
+runtime.any.system.diagnostics.tools@4.3.0
+runtime.any.system.diagnostics.tracing@4.3.0
+runtime.any.system.globalization.calendars@4.3.0
+runtime.any.system.globalization@4.3.0
+runtime.any.system.io@4.3.0
+runtime.any.system.reflection.extensions@4.3.0
+runtime.any.system.reflection.primitives@4.3.0
+runtime.any.system.reflection@4.3.0
+runtime.any.system.resources.resourcemanager@4.3.0
+runtime.any.system.runtime.handles@4.3.0
+runtime.any.system.runtime.interopservices@4.3.0
+runtime.any.system.runtime@4.3.0
+runtime.any.system.text.encoding.extensions@4.3.0
+runtime.any.system.text.encoding@4.3.0
+runtime.any.system.threading.tasks@4.3.0
+runtime.any.system.threading.timer@4.3.0
+runtime.debian.8-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.fedora.23-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.fedora.24-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.native.system.io.compression@4.1.0
+runtime.native.system.io.compression@4.3.0
+runtime.native.system.net.http@4.0.1
+runtime.native.system.net.http@4.3.0
+runtime.native.system.net.security@4.0.1
+runtime.native.system.security.cryptography.apple@4.3.0
+runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.native.system.security.cryptography@4.0.0
+runtime.native.system@4.0.0
+runtime.native.system@4.3.0
+runtime.opensuse.13.2-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.opensuse.42.1-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.apple@4.3.0
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.rhel.7-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.14.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.16.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.16.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.unix.microsoft.win32.primitives@4.3.0
+runtime.unix.system.console@4.3.0
+runtime.unix.system.diagnostics.debug@4.3.0
+runtime.unix.system.io.filesystem@4.3.0
+runtime.unix.system.net.primitives@4.3.0
+runtime.unix.system.net.sockets@4.3.0
+runtime.unix.system.private.uri@4.3.0
+runtime.unix.system.runtime.extensions@4.3.0
+skiasharp.nativeassets.linux@2.88.7
+skiasharp.nativeassets.macos@2.88.7
+skiasharp.nativeassets.webassembly@2.88.7
+skiasharp.nativeassets.win32@2.88.7
+skiasharp@2.88.7
+system.appcontext@4.1.0
+system.appcontext@4.3.0
+system.buffers@4.0.0
+system.buffers@4.3.0
+system.collections.concurrent@4.0.12
+system.collections.concurrent@4.3.0
+system.collections.immutable@1.2.0
+system.collections.immutable@5.0.0
+system.collections.nongeneric@4.3.0
+system.collections.specialized@4.3.0
+system.collections@4.0.11
+system.collections@4.3.0
+system.commandline@2.0.0-beta4.22272.1
+system.componentmodel.annotations@4.1.0
+system.componentmodel.annotations@4.5.0
+system.componentmodel.primitives@4.3.0
+system.componentmodel.typeconverter@4.3.0
+system.componentmodel@4.0.1
+system.componentmodel@4.3.0
+system.console@4.0.0
+system.console@4.3.0
+system.diagnostics.debug@4.0.11
+system.diagnostics.debug@4.3.0
+system.diagnostics.diagnosticsource@4.0.0
+system.diagnostics.diagnosticsource@4.3.0
+system.diagnostics.diagnosticsource@6.0.1
+system.diagnostics.fileversioninfo@4.0.0
+system.diagnostics.process@4.1.0
+system.diagnostics.stacktrace@4.0.1
+system.diagnostics.tools@4.0.1
+system.diagnostics.tools@4.3.0
+system.diagnostics.tracesource@4.3.0
+system.diagnostics.tracing@4.1.0
+system.diagnostics.tracing@4.3.0
+system.dynamic.runtime@4.0.11
+system.dynamic.runtime@4.3.0
+system.globalization.calendars@4.0.1
+system.globalization.calendars@4.3.0
+system.globalization.extensions@4.0.1
+system.globalization.extensions@4.3.0
+system.globalization@4.0.11
+system.globalization@4.3.0
+system.io.compression.zipfile@4.0.1
+system.io.compression.zipfile@4.3.0
+system.io.compression@4.1.0
+system.io.compression@4.3.0
+system.io.filesystem.primitives@4.0.1
+system.io.filesystem.primitives@4.3.0
+system.io.filesystem.watcher@4.0.0
+system.io.filesystem@4.0.1
+system.io.filesystem@4.3.0
+system.io.memorymappedfiles@4.0.0
+system.io.pipelines@6.0.0
+system.io.unmanagedmemorystream@4.0.1
+system.io@4.1.0
+system.io@4.3.0
+system.linq.expressions@4.1.0
+system.linq.expressions@4.3.0
+system.linq.parallel@4.0.1
+system.linq.queryable@4.0.1
+system.linq.queryable@4.3.0
+system.linq@4.1.0
+system.linq@4.3.0
+system.memory@4.5.4
+system.net.http@4.1.0
+system.net.http@4.3.0
+system.net.nameresolution@4.0.0
+system.net.nameresolution@4.3.0
+system.net.primitives@4.0.11
+system.net.primitives@4.3.0
+system.net.requests@4.0.11
+system.net.security@4.0.0
+system.net.sockets@4.1.0
+system.net.sockets@4.3.0
+system.net.webheadercollection@4.0.1
+system.numerics.vectors@4.1.1
+system.numerics.vectors@4.5.0
+system.objectmodel@4.0.12
+system.objectmodel@4.3.0
+system.private.uri@4.3.0
+system.reflection.dispatchproxy@4.0.1
+system.reflection.emit.ilgeneration@4.0.1
+system.reflection.emit.ilgeneration@4.3.0
+system.reflection.emit.lightweight@4.0.1
+system.reflection.emit.lightweight@4.3.0
+system.reflection.emit@4.0.1
+system.reflection.emit@4.3.0
+system.reflection.extensions@4.0.1
+system.reflection.extensions@4.3.0
+system.reflection.metadata@1.3.0
+system.reflection.metadata@1.6.0
+system.reflection.metadata@5.0.0
+system.reflection.primitives@4.0.1
+system.reflection.primitives@4.3.0
+system.reflection.typeextensions@4.1.0
+system.reflection.typeextensions@4.3.0
+system.reflection.typeextensions@4.5.1
+system.reflection@4.1.0
+system.reflection@4.3.0
+system.resources.reader@4.0.0
+system.resources.resourcemanager@4.0.1
+system.resources.resourcemanager@4.3.0
+system.runtime.compilerservices.unsafe@4.7.1
+system.runtime.compilerservices.unsafe@6.0.0
+system.runtime.extensions@4.1.0
+system.runtime.extensions@4.3.0
+system.runtime.handles@4.0.1
+system.runtime.handles@4.3.0
+system.runtime.interopservices.runtimeinformation@4.0.0
+system.runtime.interopservices.runtimeinformation@4.3.0
+system.runtime.interopservices@4.1.0
+system.runtime.interopservices@4.3.0
+system.runtime.loader@4.0.0
+system.runtime.numerics@4.0.1
+system.runtime.numerics@4.3.0
+system.runtime.serialization.primitives@4.1.1
+system.runtime@4.1.0
+system.runtime@4.3.0
+system.security.claims@4.0.1
+system.security.claims@4.3.0
+system.security.cryptography.algorithms@4.2.0
+system.security.cryptography.algorithms@4.3.0
+system.security.cryptography.cng@4.2.0
+system.security.cryptography.cng@4.3.0
+system.security.cryptography.csp@4.0.0
+system.security.cryptography.csp@4.3.0
+system.security.cryptography.encoding@4.0.0
+system.security.cryptography.encoding@4.3.0
+system.security.cryptography.openssl@4.0.0
+system.security.cryptography.openssl@4.3.0
+system.security.cryptography.primitives@4.0.0
+system.security.cryptography.primitives@4.3.0
+system.security.cryptography.protecteddata@4.5.0
+system.security.cryptography.x509certificates@4.1.0
+system.security.cryptography.x509certificates@4.3.0
+system.security.principal.windows@4.0.0
+system.security.principal.windows@4.3.0
+system.security.principal@4.0.1
+system.security.principal@4.3.0
+system.text.encoding.codepages@4.0.1
+system.text.encoding.codepages@4.5.1
+system.text.encoding.extensions@4.0.11
+system.text.encoding.extensions@4.3.0
+system.text.encoding@4.0.11
+system.text.encoding@4.3.0
+system.text.regularexpressions@4.1.0
+system.text.regularexpressions@4.3.0
+system.threading.overlapped@4.0.1
+system.threading.tasks.dataflow@4.6.0
+system.threading.tasks.extensions@4.0.0
+system.threading.tasks.extensions@4.3.0
+system.threading.tasks.extensions@4.5.1
+system.threading.tasks.extensions@4.5.4
+system.threading.tasks.parallel@4.0.1
+system.threading.tasks@4.0.11
+system.threading.tasks@4.3.0
+system.threading.thread@4.0.0
+system.threading.threadpool@4.0.10
+system.threading.threadpool@4.3.0
+system.threading.timer@4.0.1
+system.threading.timer@4.3.0
+system.threading@4.0.11
+system.threading@4.3.0
+system.xml.readerwriter@4.0.11
+system.xml.readerwriter@4.3.0
+system.xml.xdocument@4.0.11
+system.xml.xdocument@4.3.0
+system.xml.xmldocument@4.0.1
+system.xml.xmldocument@4.3.0
+system.xml.xpath.xdocument@4.0.1
+system.xml.xpath@4.0.1
+tmds.dbus.protocol@0.15.0
+validation@2.4.18
+xunit.abstractions@2.0.2
+xunit.abstractions@2.0.3
+xunit.analyzers@0.10.0
+xunit.assert@2.4.1
+xunit.core@2.4.1
+xunit.extensibility.core@2.4.0
+xunit.extensibility.core@2.4.1
+xunit.extensibility.execution@2.4.0
+xunit.extensibility.execution@2.4.1
+xunit.runner.visualstudio@2.3.1
+xunit.skippablefact@1.4.13
+xunit@2.4.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION="Secure Git credential storage supporing GitHub, Azure Repos, and other services"
+HOMEPAGE="https://github.com/git-ecosystem/git-credential-manager"
+SRC_URI="
+ https://github.com/git-ecosystem/git-credential-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ${NUGET_URIS}
+"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOTNET_PKG_PROJECTS=(
+ "${S}"/src/shared/Git-Credential-Manager
+)