summaryrefslogtreecommitdiff
path: root/dev-vcs/fossil/fossil-2.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/fossil/fossil-2.22.ebuild')
-rw-r--r--dev-vcs/fossil/fossil-2.22.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-vcs/fossil/fossil-2.22.ebuild b/dev-vcs/fossil/fossil-2.22.ebuild
index 7ffe54ef6335..8905c6cf1d54 100644
--- a/dev-vcs/fossil/fossil-2.22.ebuild
+++ b/dev-vcs/fossil/fossil-2.22.ebuild
@@ -15,7 +15,8 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 arm ~ppc ppc64 ~riscv x86"
IUSE="debug fusefs json system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
+ tcl-private-stubs test th1-docs th1-hooks"
+RESTRICT="!test? ( test )"
# Please check sqlite minimum version on every release. This can be done with:
# ./configure --print-minimum-sqlite-version
@@ -40,8 +41,7 @@ DEPEND="${RDEPEND}
)
"
-# Tests can't be run from the build directory
-RESTRICT="test"
+BDEPEND="test? ( dev-lang/tcl )"
PATCHES=(
# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
@@ -72,6 +72,10 @@ src_configure() {
CC_FOR_BUILD=${CC} ./configure ${myconf} || die
}
+src_test() {
+ emake test
+}
+
src_install() {
dobin fossil
}