summaryrefslogtreecommitdiff
path: root/dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild')
-rw-r--r--dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild b/dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..fda489c6a3dc
--- /dev/null
+++ b/dev-vcs/cvsgraph/cvsgraph-1.7.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ truetype? ( media-libs/freetype )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype)
+}
+
+src_install() {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README AUTHORS contrib/*.php
+ dodoc -r contrib/automatic_documentation
+}