summaryrefslogtreecommitdiff
path: root/dev-vcs/bzr-xmloutput
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bzr-xmloutput')
-rw-r--r--dev-vcs/bzr-xmloutput/Manifest4
-rw-r--r--dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild27
-rw-r--r--dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch220
-rw-r--r--dev-vcs/bzr-xmloutput/metadata.xml8
4 files changed, 259 insertions, 0 deletions
diff --git a/dev-vcs/bzr-xmloutput/Manifest b/dev-vcs/bzr-xmloutput/Manifest
new file mode 100644
index 000000000000..0a8305e521d1
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/Manifest
@@ -0,0 +1,4 @@
+AUX bzr-xmloutput-0.8.8_remove-relative-imports.patch 5175 BLAKE2B 5ec184209d5da05c52685f7783d5e80115f29c1004c341b0fc6223efa3314bf7a7242f3513488f8ef2f20a2967e460904ec787ef9fb379fe591636718655d957 SHA512 209b3e4df0123a85a34d9b1f3cb2706fe61ab3bf779011cb16cabcc92245204c06d5be6ab16def6389fadb882b8ff8da5b0551baba988354ef95a777fff355b7
+DIST bzr-xmloutput-0.8.8.tar.gz 49969 BLAKE2B 728783e8d68063c639d153b334116c109f90493d80f7384f4e25deceb97e67843ad27676ac70403124163ebec745adf58fdda38515db3932ff87684e60537377 SHA512 9eb87ba86dd45b7132eca69ef6e52726d7ee2d9211cc3052655e40f5cee2b99e160336c347ddce7ad912c0027e8b6a05ca542f70733d2e3493922cfa311b38ef
+EBUILD bzr-xmloutput-0.8.8-r2.ebuild 611 BLAKE2B 746d20ac3a8035203dd3bf20bbb7618ea91301b3572c1c2b695295a04b7deec6cbe28ace76f471a9f46f21012b8d4d8b03d11387f078fa3696d2e762bb138653 SHA512 6235679d5ca3bf0dbed7f4f455f37bd11d117b3c2f1baf83db554cd2610681a4ab69dae51e8d9ea1cc5b344afb77a9bc5e19b0d1d9eae780a375afabbe9c28d6
+MISC metadata.xml 253 BLAKE2B e68e5578eb3a3b0fecc4d9d53d9df965024851ea16c468ad728307064315ddf8547152e27f3c4a45e1b01f3763b0e7650dc6daa4f067d02dad00194379762bb0 SHA512 4fed0d9c18fc0528aaa734f5d16a7e1a36f582fb4b82365d8515301b04389b98431dfb61868c1e69a50b5cf8b5e19e73cd0facdb3ead5eef094eb24cda3ddbb3
diff --git a/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild
new file mode 100644
index 000000000000..6006269067ab
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Bazaar plugin providing an option to generate XML output for builtin commands"
+HOMEPAGE="http://bazaar-vcs.org/XMLOutput"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/bzr[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${P}_remove-relative-imports.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch b/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch
new file mode 100644
index 000000000000..b21eef05d2ad
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch
@@ -0,0 +1,220 @@
+revno: 160 [merge]
+author: Jelmer Vernooij <jelmer@samba.org>
+committer: Guillermo Gonzalez <guillo.gonzo@gmail.com>
+branch nick: trunk
+timestamp: Mon 2011-12-19 18:45:35 -0300
+message:
+ Removes the use of relative imports and avoids using lazy_import in a few places we're it doesn't make a difference.
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=418969
+Upstream bug: https://bugs.launchpad.net/bzr-xmloutput/+bug/955329
+Commit: http://bazaar.launchpad.net/~verterok/bzr-xmloutput/trunk/revision/160
+
+--- cmds.py 2011-03-09 23:19:41 +0000
++++ cmds.py 2011-12-12 15:11:38 +0000
+@@ -22,36 +22,39 @@
+
+ import info
+ import bzrlib
++from bzrlib.option import Option
++from bzrlib.commands import (
++ Command,
++ display_command,
++ )
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import sys
+ from bzrlib import (
+ builtins,
+ bzrdir,
+- commands,
+- option,
+ log,
+ workingtree,
+ errors
+ )
+
+-from bzrlib.option import Option, custom_help
+-from bzrlib.commands import display_command
+-import logxml
+-import service
++from bzrlib.plugins.xmloutput import (
++ logxml,
++ service,
++ )
+ import socket
+-from xml_errors import handle_error_xml
+ """)
+
++from bzrlib.plugins.xmloutput.xml_errors import handle_error_xml
+
+ version_info = info.bzr_plugin_version
+ plugin_name = info.bzr_plugin_name
+
+-null_option = option.Option('null',
+- help='Write an ascii NUL (\\0) as the final char.')
+-
+-
+-class cmd_xmlstatus(commands.Command):
++null_option = Option('null',
++ help='Write an ascii NUL (\\0) as the final char.')
++
++
++class cmd_xmlstatus(Command):
+ """Display status summary.
+
+ This reports on versioned and unknown files, reporting them
+@@ -118,7 +121,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlannotate(commands.Command):
++class cmd_xmlannotate(Command):
+ """Show the origin of each line in a file.
+
+ This prints out the given file with an annotation on the left side
+@@ -176,7 +179,7 @@
+ branch.unlock()
+
+
+-class cmd_xmlmissing(commands.Command):
++class cmd_xmlmissing(Command):
+ """Show unmerged/unpulled revisions between two branches.
+
+ OTHER_BRANCH may be local or remote.
+@@ -212,7 +215,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlinfo(commands.Command):
++class cmd_xmlinfo(Command):
+ """Show information about a working tree, branch or repository.
+
+ This command will show all known locations and formats associated to the
+@@ -247,7 +250,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlplugins(commands.Command):
++class cmd_xmlplugins(Command):
+ """List the installed plugins.
+
+ This command displays the list of installed plugins including
+@@ -284,7 +287,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlversion(commands.Command):
++class cmd_xmlversion(Command):
+ """Show version of bzr."""
+ hidden = True
+ encoding_type = 'replace'
+@@ -383,7 +386,7 @@
+ self.outf.write('\0')
+ self.outf.write('\n')
+
+-class cmd_start_xmlrpc(commands.Command):
++class cmd_start_xmlrpc(Command):
+ """Start the xmlrpc service."""
+
+ hidden = True
+@@ -413,7 +416,7 @@
+ self.server.shutdown()
+
+
+-class cmd_stop_xmlrpc(commands.Command):
++class cmd_stop_xmlrpc(Command):
+ """Stops a xmlrpc service."""
+
+ hidden = True
+
+--- infoxml.py 2009-07-28 03:43:56 +0000
++++ infoxml.py 2011-12-12 15:11:38 +0000
+@@ -27,6 +27,7 @@
+
+ __all__ = ['show_bzrdir_info_xml']
+
++from bzrlib import info
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import os, sys, time
+@@ -36,7 +37,6 @@
+ errors,
+ osutils,
+ urlutils,
+- info,
+ missing,
+ )
+ """)
+
+--- logxml.py 2010-12-15 18:27:12 +0000
++++ logxml.py 2011-12-12 15:11:38 +0000
+@@ -1,14 +1,12 @@
+ # -*- encoding: utf-8 -*-
+
+-import os
+-
++from bzrlib import log
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import bzrlib
+ from bzrlib import (
+ debug,
+ osutils,
+- log,
+ )
+ """)
+
+
+--- lsxml.py 2011-03-09 23:41:22 +0000
++++ lsxml.py 2011-12-12 15:11:38 +0000
+@@ -19,8 +19,6 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+ #
+
+-import os
+-
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ from bzrlib import bzrdir, errors, osutils
+
+--- service.py 2010-02-23 23:38:02 +0000
++++ service.py 2011-12-12 15:11:38 +0000
+@@ -20,6 +20,8 @@
+ #
+ """ xmlrpc service module """
+
++import os
++
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import bzrlib
+@@ -30,14 +32,13 @@
+ osutils
+ )
+ import sys
+-import os
+ import codecs
+ import logging
+ import traceback
+ from cStringIO import StringIO
+ """)
+
+-from xml_errors import XMLError
++from bzrlib.plugins.xmloutput.xml_errors import XMLError
+ from xmlrpclib import Fault, Binary
+ from SimpleXMLRPCServer import SimpleXMLRPCServer
+
+
+--- statusxml.py 2010-12-15 18:27:12 +0000
++++ statusxml.py 2011-12-12 15:11:38 +0000
+@@ -33,7 +33,7 @@
+ trace,
+ )
+
+-import logxml
++from bzrlib.plugins.xmloutput import logxml
+ """)
+
+ from writer import _escape_cdata
+
diff --git a/dev-vcs/bzr-xmloutput/metadata.xml b/dev-vcs/bzr-xmloutput/metadata.xml
new file mode 100644
index 000000000000..1cdf0a3530fa
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="launchpad">bzr-xmloutput</remote-id>
+ </upstream>
+</pkgmetadata>