summaryrefslogtreecommitdiff
path: root/dev-util/watchman
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/watchman')
-rw-r--r--dev-util/watchman/Manifest2
-rw-r--r--dev-util/watchman/watchman-2023.06.19.00.ebuild6
2 files changed, 5 insertions, 3 deletions
diff --git a/dev-util/watchman/Manifest b/dev-util/watchman/Manifest
index 64275a785943..6e3e1834c9e6 100644
--- a/dev-util/watchman/Manifest
+++ b/dev-util/watchman/Manifest
@@ -108,5 +108,5 @@ DIST windows_i686_msvc-0.48.0.crate 730056 BLAKE2B 4e4ad6ed94948145199c2ed50fc65
DIST windows_x86_64_gnu-0.48.0.crate 703595 BLAKE2B b227efb78a99c43d0538cceadada3fa1840df29adc665787fdcf845b73e77d782da8a9f9aa602e1da61401b550d0107176feb6c397c922a6240b38cc8f04a180 SHA512 38eff1164fb37dbd2bbe53404b20cba92de84cbbd5e4eb9ad60d51fb43d6fdb8b87a1488e2c88ebd4b3ff3b708f93fdc05df4b14a285d3ff11c33ff0d9828602
DIST windows_x86_64_gnullvm-0.48.0.crate 366536 BLAKE2B 295dc3aef18c604d1579978045f4058b1a315083a8ab842bddf5800ec3460b1530ad88c3464acab712a229290aca235810de8a3b6a253859a354d9fa97277e58 SHA512 8d82fad4c8445030844708aa026a62f1ca43362b8e15f14b0d226c7e9cda04ffa0715087b6a025dbb738e8891de24fcc4a2df071a532917cf03c4a46f934f396
DIST windows_x86_64_msvc-0.48.0.crate 671422 BLAKE2B abb063610dcc38581657133182b7d9efeed5553df67bd2bd6f30f1668a645186e4824f9ef556a5abc84ace10b1b437b6325bbda6df5a64ce880d7dcb743ac786 SHA512 6e598b8e3ac54912a8ebac01b0dd2c58fd282072527d7fedc7f6ebecdfb7dcb09ae46c22293bc0117849437f8b053db5e90406e7a38276f0f0afd06be3966795
-EBUILD watchman-2023.06.19.00.ebuild 5446 BLAKE2B 02cbe5f8c52d23cbc93c18fe345192fa0debac3c36a49db265ef4244167581d0d5fb8bf10a6568bc552759dcccb87a18df0590a95f15ada38d047d046cad1cf9 SHA512 8b8e8a63fa11ef96cdbd21da43fff577ff226b23aba143a1294bdf2ddea474cde95ba81349b992f3434b24629e8ca90dbdbbba3e1c90f6c49a901e5b474dbd53
+EBUILD watchman-2023.06.19.00.ebuild 5463 BLAKE2B f08b0861f87e84451e669f5f9f04d57eba8ab966f68362931a932835740bb581dd1c68a19137da883801c5f07a72c4d6b5113b855013278d31d2d85b4b3470eb SHA512 d924851069f5bac429d9a6a4dd47ad61d67f88777e9b61adf4e33834fd54c9686d521ee5cc357ad81589a414d89caad14e29b6669efdf48c2a9cdd3d07838902
MISC metadata.xml 429 BLAKE2B e69d0fb854d42a000fdc5609c7c6a12b8928eef97630b9043813a44da1bb24639648cf8a412ae7a2d0c0b7e058e2a2df65d33ee7f5198c1aea3253106d43cc75 SHA512 bf683e13fc81e5bfea3dcd80edf4a10fdae95807074035e0f8a63be4d7137488a92396b7bdcdbff5a539922f6d3fd57b67c5e5720a27b3d471d29c96b3b061ff
diff --git a/dev-util/watchman/watchman-2023.06.19.00.ebuild b/dev-util/watchman/watchman-2023.06.19.00.ebuild
index d67d11bf1daa..55b90312e885 100644
--- a/dev-util/watchman/watchman-2023.06.19.00.ebuild
+++ b/dev-util/watchman/watchman-2023.06.19.00.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -122,8 +122,10 @@ CRATES="
windows_x86_64_msvc@0.48.0
"
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit cargo cmake distutils-r1 tmpfiles
DESCRIPTION="A file watching service"