summaryrefslogtreecommitdiff
path: root/dev-util/sysprof
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-47.2.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 6d5181126727..8aaeec058bcb 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,5 +1,7 @@
DIST sysprof-3.48.0.tar.xz 533092 BLAKE2B 5af48d9216f13ffcc8824b0ba6a4e0ff931c903991953e66c2b50534399320d3d3fccd6e8478b10dc895d19544f9c08733565d95fe9c2c70d64f2294ccce2330 SHA512 100b79fabee005b5445dab3ad78d43facf375a488aa6513e987deecd6a3036cc43bfd78db106a4b8a15b4280dcd975872784c839f560779183adb5a339b0648c
DIST sysprof-46.0.tar.xz 1170396 BLAKE2B 6455d31c00509540d43137863e330dc0dff49887108f80091b4374630e91a9c1c8e16c8475f6c3e992e7e416dfb3fe19e14e6e466c37424d960b91ba6c65e5a6 SHA512 f04d887218257d177f7bc68485bcc47c310188335530ff9bf5e3efa7c383d56e97d5d969b2e8b5b0469993456aa734873c599f3d743615716305b8c7f113f534
+DIST sysprof-47.2.tar.xz 1192172 BLAKE2B c36c031811b0bc87c8d93ebc8fc4debb56995e4a43e486603c81742ab25093cfb958f255c5f0c9589aa70fed0796a6141923d82d69e12f677066b7a70a4d342d SHA512 3673b8035ba115f581c3d4d881a6ac99f15d96d461f5d0824d727cfb504ae41363c5b5e0fc117acd202b203c251bb514e53307799c1dbea1d2b0d320ed2fd104
EBUILD sysprof-3.48.0-r1.ebuild 2538 BLAKE2B 76497bdacdac875323af6b6175d8764af993925ed3e21bae39a8462f46e9a883bdcfd629c34e860de9315d52dbf0ea35add0c1edd4d6c34821ba9f6600612005 SHA512 82349b8d3947063372390c3a39f29563f8461863076e9e051d24d4d6861cff9269c6a3f9a6091735fa73afdff64c89f927c069eef19e5af8834708273c5852dc
EBUILD sysprof-46.0-r1.ebuild 2607 BLAKE2B d804ddbb2a15003106f83c5a34bbf4b7973099eada87f1b854dce244ad1c247ae81b317e2f8f6157e32908059cb69a39f60dfb19c184b63cb21b858f9fe2a587 SHA512 b09e9d1000e435dda94ebb946a5176ea78444dcb87e0c9eb5c0b830b070e0899153bd00644dcb65bf8f255f5da1062a81cd78ab450cc6fcf7a1c6fde94e7232a
+EBUILD sysprof-47.2.ebuild 2693 BLAKE2B 48c35eb11b18fe45f72a529291f0276d543e2bf39028b908dde92d1a5061978edbf2e7a00136a853867cb428ba6a7ec5a0b742caa278cb7e5719c3fd480034fd SHA512 ec92794c3e0ccd821c77ff480a0b32c5a1715d41f355c21e1749d2e8b45837570dba1524a9b9e8b214cb6dc4745a679d96ea132706a77f99f715cdf5678f1555
MISC metadata.xml 833 BLAKE2B 35f88ffbe55a8acf5322b2f30556b950d2cdf148e0e16d1dcf8eac080273419bdca505088d4cea12c01cd2644fe9129995dfb497177aac70dbd75c82ed018917 SHA512 de169c39ab639a120f4ca13d5619fdb531239cfcb2af90c7fc0c4b7d234002fca5b9f2f1cbc8ab305648a7a13bd116d2c1addd2e32f2d04e7ef37118dd2af913
diff --git a/dev-util/sysprof/sysprof-47.2.ebuild b/dev-util/sysprof/sysprof-47.2.ebuild
new file mode 100644
index 000000000000..5b6fd9b96100
--- /dev/null
+++ b/dev-util/sysprof/sysprof-47.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils greadme meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+API_VERSION="4"
+SLOT="0/${API_VERSION}"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+IUSE="gtk systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.76.0:2
+ gtk? (
+ >=gui-libs/gtk-4.15:4
+ >=gui-libs/libadwaita-1.6_alpha:1
+ x11-libs/cairo
+ x11-libs/pango
+ )
+ systemd? ( sys-apps/systemd )
+ dev-libs/json-glib
+ >=dev-libs/libdex-0.6
+ >=gui-libs/libpanel-1.7.0
+ sys-libs/libunwind:=
+ >=sys-auth/polkit-0.114[daemon]
+ >=dev-util/sysprof-common-${PV}
+ >=dev-util/sysprof-capture-${PV}:${API_VERSION}
+"
+DEPEND="
+ ${RDEPEND}
+ !systemd? ( !!sys-apps/systemd )
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # These are installed by dev-util/sysprof-capture
+ sed -i \
+ -e '/install: not meson.is_subproject/d' \
+ -e '/install.*sysprof_header_subdir/d' \
+ -e 's/pkgconfig\.generate/subdir_done()\npkgconfig\.generate/' \
+ src/libsysprof-capture/meson.build || die
+}
+
+src_configure() {
+ # -Dsysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk)
+ -Dlibsysprof=true
+ -Dinstall-static=false
+ -Dsysprofd=bundled
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=true
+ -Dtools=true
+ $(meson_use test tests)
+ -Dexamples=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # We want to ship org.gnome.Sysprof3.Profiler.xml in sysprof-common for the benefit of x11-wm/mutter
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml || die
+
+ greadme_stdin <<-EOF
+ On many systems, especially amd64, it is typical that with a modern
+ toolchain -fomit-frame-pointer for gcc is the default, because
+ debugging is still possible thanks to gcc/gdb location list feature.
+ However sysprof is not able to construct call trees if frame pointers
+ are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested
+ for the libraries and applications involved in the profiling. That
+ means a CPU register is used for the frame pointer instead of other
+ purposes, which means a very minimal performance loss when there is
+ register pressure.
+EOF
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+ greadme_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ greadme_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}