summaryrefslogtreecommitdiff
path: root/dev-util/strace/strace-4.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-4.20.ebuild')
-rw-r--r--dev-util/strace/strace-4.20.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-util/strace/strace-4.20.ebuild b/dev-util/strace/strace-4.20.ebuild
index 458e7d64d80e..e445febc7869 100644
--- a/dev-util/strace/strace-4.20.ebuild
+++ b/dev-util/strace/strace-4.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,15 @@ src_configure() {
econf $(use_with unwind libunwind)
}
+src_test() {
+ if has usersandbox $FEATURES ; then
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
+ return 0
+ fi
+
+ default
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph