summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck/shellcheck-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/shellcheck/shellcheck-0.7.1.ebuild')
-rw-r--r--dev-util/shellcheck/shellcheck-0.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/shellcheck/shellcheck-0.7.1.ebuild b/dev-util/shellcheck/shellcheck-0.7.1.ebuild
new file mode 100644
index 000000000000..357bb0ecd576
--- /dev/null
+++ b/dev-util/shellcheck/shellcheck-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ShellCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Shell script analysis tool"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/diff-0.2.0:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?]
+ >=dev-haskell/parsec-3.0:=[profile?]
+ >=dev-haskell/quickcheck-2.7.4:2=[template-haskell,profile?]
+ dev-haskell/regex-tdfa:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+S="${WORKDIR}/${MY_P}"