summaryrefslogtreecommitdiff
path: root/dev-util/scons/scons-4.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scons/scons-4.2.0-r1.ebuild')
-rw-r--r--dev-util/scons/scons-4.2.0-r1.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/dev-util/scons/scons-4.2.0-r1.ebuild b/dev-util/scons/scons-4.2.0-r1.ebuild
index d4f1339f581a..5a28706a03d0 100644
--- a/dev-util/scons/scons-4.2.0-r1.ebuild
+++ b/dev-util/scons/scons-4.2.0-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Extensible Python-based build utility"
HOMEPAGE="https://www.scons.org/"
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"
RESTRICT="!test? ( test )"
@@ -73,6 +73,24 @@ src_prepare() {
test/option/option-v.py
test/Interactive/version.py
)
+
+ if ! use amd64 && ! use x86 ; then
+ # These tests are currently broken on arm and other non-amd64/x86 platforms
+ # Work seems to be ongoing in e.g. https://github.com/SCons/scons/pull/4022 to
+ # better plumb up the MSVC tests for alternative arches.
+ # Try again after 4.2.0.
+ # See also: https://pairlist4.pair.net/pipermail/scons-users/2020-November/008452.html
+ # bug #757534
+ remove_tests+=(
+ test/MSVS/vs-7.0-scc-files.py
+ test/MSVS/vs-7.0-scc-legacy-files.py
+ test/MSVS/vs-7.1-scc-files.py
+ test/MSVS/vs-7.1-scc-legacy-files.py
+ test/MSVS/vs-scc-files.py
+ test/MSVS/vs-scc-legacy-files.py
+ )
+ fi
+
rm -r "${remove_tests[@]}" || die
fi
}