summaryrefslogtreecommitdiff
path: root/dev-util/re2c/re2c-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/re2c/re2c-2.2.ebuild')
-rw-r--r--dev-util/re2c/re2c-2.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-2.2.ebuild b/dev-util/re2c/re2c-2.2.ebuild
new file mode 100644
index 000000000000..2c4d64c19311
--- /dev/null
+++ b/dev-util/re2c/re2c-2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug test"
+
+RESTRICT="!test? ( test )"
+
+# python is used only as a test driver
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --enable-golang \
+ ac_cv_path_BISON="no" \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r README.md CHANGELOG examples
+}