summaryrefslogtreecommitdiff
path: root/dev-util/radare2/radare2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/radare2/radare2-9999.ebuild')
-rw-r--r--dev-util/radare2/radare2-9999.ebuild26
1 files changed, 24 insertions, 2 deletions
diff --git a/dev-util/radare2/radare2-9999.ebuild b/dev-util/radare2/radare2-9999.ebuild
index 36cda6bb0ae0..963c0b6b6e74 100644
--- a/dev-util/radare2/radare2-9999.ebuild
+++ b/dev-util/radare2/radare2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1 eutils
+inherit bash-completion-r1 eutils toolchain-funcs
DESCRIPTION="unix-like reverse engineering framework and commandline tools"
HOMEPAGE="http://www.radare.org"
@@ -21,6 +21,10 @@ SLOT="0"
IUSE="ssl libressl"
RDEPEND="
+ dev-libs/libzip
+ dev-libs/xxhash
+ sys-apps/file
+ sys-libs/zlib
dev-libs/capstone:0=
ssl? (
!libressl? ( dev-libs/openssl:0= )
@@ -30,10 +34,24 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ # Fix hardcoded docdir for fortunes
+ sed -i -e "/^#define R2_FORTUNES/s/radare2/$PF/" \
+ libr/include/r_userconf.h.acr
+ default
+}
+
src_configure() {
+ # Ideally these should be set by ./configure
+ tc-export CC AR LD OBJCOPY RANLIB
+ export HOST_CC=${CC}
+
econf \
--without-libuv \
--with-syscapstone \
+ --with-sysmagic \
+ --with-sysxxhash \
+ --with-syszip \
$(use_with ssl openssl)
}
@@ -53,4 +71,8 @@ src_install() {
rm -rfv "$d" || die "failed to delete '$d'"
fi
done
+
+ # These are not really docs. radare assumes
+ # uncompressed files: bug #761250
+ docompress -x /usr/share/doc/${PF}/fortunes.{creepy,fun,nsfw,tips}
}