summaryrefslogtreecommitdiff
path: root/dev-util/pretrace/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pretrace/files')
-rw-r--r--dev-util/pretrace/files/pretrace-0.4-build.patch4
-rw-r--r--dev-util/pretrace/files/pretrace-0.4-qa.patch39
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-util/pretrace/files/pretrace-0.4-build.patch b/dev-util/pretrace/files/pretrace-0.4-build.patch
index 4d7056fa83f7..9db1cb241e7b 100644
--- a/dev-util/pretrace/files/pretrace-0.4-build.patch
+++ b/dev-util/pretrace/files/pretrace-0.4-build.patch
@@ -2,8 +2,8 @@ fix building with newer glibc
http://bugs.gentoo.org/227923
---- pretrace.h
-+++ pretrace.h
+--- a/pretrace.h
++++ b/pretrace.h
@@ -20,3 +20,8 @@
#include <sys/time.h>
# define RANDOMIZE(x) { struct timeval tv; gettimeofday(&tv, NULL); x = tv.tv_usec; }
diff --git a/dev-util/pretrace/files/pretrace-0.4-qa.patch b/dev-util/pretrace/files/pretrace-0.4-qa.patch
new file mode 100644
index 000000000000..8cf40e796a12
--- /dev/null
+++ b/dev-util/pretrace/files/pretrace-0.4-qa.patch
@@ -0,0 +1,39 @@
+--- pretrace-0.4/Makefile.orig 2021-01-14 13:31:45.950615134 +0300
++++ pretrace-0.4/Makefile 2021-01-14 13:32:04.940676578 +0300
+@@ -2,14 +2,14 @@
+ # $Id: Makefile,v 1.1 2005/07/27 07:45:37 taviso Exp $
+ #
+
+-VERSION=0.4
++VERSION?=0.4
+ PREFIX=/usr/local
+ DOCDIR=$(PREFIX)/share/doc/pretrace-$(VERSION)
+ LIBDIR=$(PREFIX)/lib
+ BINDIR=$(PREFIX)/bin
+ MANDIR=$(PREFIX)/share/man
+
+-all: libpretrace.so ptgenmap doc
++all: libpretrace.so ptgenmap
+ @echo 'libpretrace.so has been built, please see README for instructions.'
+ @echo 'type `make install` to install to $(PREFIX)'
+
+@@ -26,7 +26,7 @@
+ $(CC) $(CFLAGS) -Wall -g -fPIC -c trie.c
+
+ libpretrace.so: libpretrace.o trie.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -g -shared -o libpretrace.so libpretrace.o trie.o
++ $(CC) $(CFLAGS) $(LDFLAGS) -g -shared -Wl,-soname,libpretrace.so -o libpretrace.so libpretrace.o trie.o
+
+ doc:
+ gzip -9c pretrace.3 > pretrace.3.gz
+@@ -38,8 +41,8 @@
+ install -m 0755 libpretrace.so $(LIBDIR)
+ install -m 0755 ptgenmap $(BINDIR)
+ install -m 0644 README pretrace.conf.example ChangeLog $(DOCDIR)
+- install -m 0644 pretrace.3.gz $(MANDIR)/man3
+- install -m 0644 ptgenmap.8.gz $(MANDIR)/man8
++ install -m 0644 pretrace.3 $(MANDIR)/man3
++ install -m 0644 ptgenmap.8 $(MANDIR)/man8
+
+ clean:
+ -rm -f libpretrace.so libpretrace.o trie.o ptgenmap.o ptgenmap *~