summaryrefslogtreecommitdiff
path: root/dev-util/pkgdev/pkgdev-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgdev/pkgdev-9999.ebuild')
-rw-r--r--dev-util/pkgdev/pkgdev-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-util/pkgdev/pkgdev-9999.ebuild b/dev-util/pkgdev/pkgdev-9999.ebuild
index 6a425ed841c9..041813b0cea7 100644
--- a/dev-util/pkgdev/pkgdev-9999.ebuild
+++ b/dev-util/pkgdev/pkgdev-9999.ebuild
@@ -15,7 +15,7 @@ else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi
-DESCRIPTION="pkgcore-based git QA tool"
+DESCRIPTION="Collection of tools for Gentoo development"
HOMEPAGE="https://github.com/pkgcore/pkgdev"
LICENSE="BSD MIT"
@@ -26,15 +26,23 @@ if [[ ${PV} == *9999 ]] ; then
RDEPEND="
~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
~dev-util/pkgcheck-9999[${PYTHON_USEDEP}]
- dev-vcs/git
~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
"
+else
+ # https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
+ RDEPEND="
+ >=dev-python/snakeoil-0.9.3[${PYTHON_USEDEP}]
+ >=dev-util/pkgcore-0.11.4[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.9.1[${PYTHON_USEDEP}]
+ "
fi
-# Releases (in future): https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
+# Uses pytest but we want to use the setup.py runner to get generated modules
+BDEPEND+="test? ( dev-python/pytest )"
+RDEPEND+="dev-vcs/git"
distutils_enable_sphinx doc
-distutils_enable_tests pytest
+distutils_enable_tests setup.py
python_install_all() {
# We'll generate man pages ourselves