summaryrefslogtreecommitdiff
path: root/dev-util/pkgdev/pkgdev-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgdev/pkgdev-9999.ebuild')
-rw-r--r--dev-util/pkgdev/pkgdev-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/pkgdev/pkgdev-9999.ebuild b/dev-util/pkgdev/pkgdev-9999.ebuild
index 3344f643aa2f..8902eff76956 100644
--- a/dev-util/pkgdev/pkgdev-9999.ebuild
+++ b/dev-util/pkgdev/pkgdev-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~riscv ~x64-macos"
+ KEYWORDS="~amd64 ~ppc64 ~riscv ~sparc ~x64-macos"
fi
DESCRIPTION="Collection of tools for Gentoo development"
@@ -31,9 +31,9 @@ if [[ ${PV} == *9999 ]] ; then
else
# https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
RDEPEND="
- >=dev-python/snakeoil-0.9.4[${PYTHON_USEDEP}]
- >=dev-util/pkgcheck-0.9.1[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.11.5[${PYTHON_USEDEP}]
+ >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]
+ >=dev-util/pkgcheck-0.10.0[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.12.0[${PYTHON_USEDEP}]
"
fi