summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-0.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-0.10.2.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.2.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.2.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.2.ebuild
deleted file mode 100644
index 9a255efb0571..000000000000
--- a/dev-util/pkgcheck/pkgcheck-0.10.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1 optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="pkgcore-based QA utility for ebuild repos"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD MIT"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND="
- >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.12.1[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pathspec[${PYTHON_USEDEP}]
- >=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests setup.py
-
-src_test() {
- local -x PYTHONDONTWRITEBYTECODE=
- distutils-r1_src_test
-}
-
-python_install_all() {
- local DOCS=( NEWS.rst )
- [[ ${PV} == *9999 ]] || doman man/*
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Network check support" dev-python/requests
- optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
-}