summaryrefslogtreecommitdiff
path: root/dev-util/perf/perf-5.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/perf/perf-5.11.ebuild')
-rw-r--r--dev-util/perf/perf-5.11.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-util/perf/perf-5.11.ebuild b/dev-util/perf/perf-5.11.ebuild
index eda4faf8ef8e..92f4c1ae43f6 100644
--- a/dev-util/perf/perf-5.11.ebuild
+++ b/dev-util/perf/perf-5.11.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
-inherit bash-completion-r1 estack eutils llvm toolchain-funcs prefix python-r1 linux-info
+inherit bash-completion-r1 estack llvm toolchain-funcs prefix python-r1 linux-info
DESCRIPTION="Userland tools for Linux Performance Counters"
HOMEPAGE="https://perf.wiki.kernel.org/"
@@ -40,12 +40,15 @@ BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
sys-devel/bison
sys-devel/flex
+ virtual/pkgconfig
doc? (
app-text/asciidoc
app-text/sgml-common
app-text/xmlto
sys-process/time
- )"
+ )
+ ${PYTHON_DEPS}
+"
RDEPEND="audit? ( sys-process/audit )
crypt? ( dev-libs/openssl:0= )
@@ -87,6 +90,9 @@ pkg_pretend() {
pkg_setup() {
use clang && LLVM_MAX_SLOT=9 llvm_pkg_setup
+ # We enable python unconditionally as libbpf always generates
+ # API headers using python script
+ python_setup
}
src_unpack() {