summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf/patchelf-0.13.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.13.ebuild b/dev-util/patchelf/patchelf-0.13.ebuild
new file mode 100644
index 000000000000..e66de9a4aec2
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}