summaryrefslogtreecommitdiff
path: root/dev-util/pahole/pahole-1.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pahole/pahole-1.22.ebuild')
-rw-r--r--dev-util/pahole/pahole-1.22.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-util/pahole/pahole-1.22.ebuild b/dev-util/pahole/pahole-1.22.ebuild
deleted file mode 100644
index 90c3dc91f27b..000000000000
--- a/dev-util/pahole/pahole-1.22.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit multilib cmake python-single-r1
-
-DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
-HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
-
-LICENSE="GPL-2" # only
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="debug"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/elfutils-0.178
- sys-libs/zlib"
-DEPEND="${RDEPEND}"
-
-MY_PN=dwarves
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-if [[ ${PV//_p} == ${PV} ]]; then
- SRC_URI="http://fedorapeople.org/~acme/${MY_PN}/${MY_P}.tar.xz"
-else
- SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
-fi
-
-DOCS=( README README.ctracer NEWS )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.10-python-import.patch
-)
-
-src_prepare() {
- cmake_src_prepare
- python_fix_shebang ostra/ostra-cg ostra/python/ostra.py
-}
-
-src_configure() {
- local mycmakeargs=( "-D__LIB=$(get_libdir)" )
- cmake_src_configure
-}
-
-src_test() { :; }
-
-src_install() {
- cmake_src_install
-}