summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.6.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/packer/packer-1.6.6.ebuild')
-rw-r--r--dev-util/packer/packer-1.6.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.6.6.ebuild b/dev-util/packer/packer-1.6.6.ebuild
new file mode 100644
index 000000000000..302cc7c43eea
--- /dev/null
+++ b/dev-util/packer/packer-1.6.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ go build \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}