summaryrefslogtreecommitdiff
path: root/dev-util/osc/osc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/osc/osc-9999.ebuild')
-rw-r--r--dev-util/osc/osc-9999.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/osc/osc-9999.ebuild b/dev-util/osc/osc-9999.ebuild
deleted file mode 100644
index bd32f689995e..000000000000
--- a/dev-util/osc/osc-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/openSUSE/${PN}.git"
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-if [[ "${PV}" == "9999" ]]; then
- EXTRA_ECLASS="git-r3"
-else
- OBS_PROJECT="openSUSE:Tools"
- EXTRA_ECLASS="obs-download"
-fi
-
-DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 ${EXTRA_ECLASS}
-unset EXTRA_ECLASS
-
-DESCRIPTION="Command line tool for Open Build Service"
-HOMEPAGE="https://en.opensuse.org/openSUSE:OSC"
-
-[[ "${PV}" == "9999" ]] || SRC_URI="${OBS_URI}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ "${PV}" == "9999" ]] || \
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- dev-python/urlgrabber[${PYTHON_USEDEP}]
- app-arch/rpm[python,${PYTHON_USEDEP}]
- dev-python/m2crypto[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
-"
-PDEPEND="${DEPEND}
- app-admin/sudo
- dev-util/obs-service-meta
-"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.139.2-out-of-tree-build.patch
- distutils-r1_src_prepare
-}
-
-src_install() {
- distutils-r1_src_install
- dosym osc-wrapper.py /usr/bin/osc
- keepdir /usr/lib/osc/source_validators
- cd "${ED}"/usr/
- find . -type f -exec sed -i 's|/usr/bin/build|/usr/bin/suse-build|g' {} +
- find . -type f -exec sed -i 's|/usr/lib/build|/usr/libexec/suse-build|g' {} +
- find . -type f -exec sed -i 's|/usr/lib/obs|/usr/libexec/obs|g' {} +
- rm -f "${ED}"/usr/share/doc/${PN}*/TODO*
-}