summaryrefslogtreecommitdiff
path: root/dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild b/dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild
new file mode 100644
index 000000000000..46d065988f56
--- /dev/null
+++ b/dev-util/opencl-headers/opencl-headers-2021.06.30.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="OpenCL-Headers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unified C language headers for the OpenCL API"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-Headers"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/include
+ doins -r "${S}"/CL
+}