summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
index 9efc43518403..f8c49eccf6eb 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
@@ -38,8 +38,13 @@ pkg_setup() {
mingw-foreach_tool() {
use !tools || use headers-only && return
- local tool
- for tool in gendef genidl widl; do
+ local tool=widl
+ if use !amd64 && use !x86 && use !arm64 && use !arm; then
+ einfo "Skipping widl due to unsupported platform" #853250
+ tool=
+ fi
+
+ for tool in gendef genidl ${tool}; do
# not using top-level --with-tools given it skips widl
pushd mingw-w64-tools/${tool} >/dev/null || die
"${@}"
@@ -49,9 +54,7 @@ mingw-foreach_tool() {
src_configure() {
# native tools, see #644556
- local toolsconf=(
- --prefix="${EPREFIX}"/usr
- )
+ local toolsconf=()
# normally only widl is prefixed, but avoids clash with other targets
${MW_CROSS} && toolsconf+=( --program-prefix=${CTARGET}- )