summaryrefslogtreecommitdiff
path: root/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw-runtime/mingw-runtime-3.18.ebuild')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.18.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
deleted file mode 100644
index 74ba9950cae3..000000000000
--- a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-inherit flag-o-matic eutils
-
-MY_P="mingwrt-${PV}-mingw32"
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="headers-only"
-RESTRICT="strip"
-
-S=${WORKDIR}/${MY_P}
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-just_headers() {
- use headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc-4.6.patch #419627
- sed -i \
- -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
- $(find -name configure) || die
- sed -i \
- -e '/^install_dlls_host:/s:$: install-dirs:' \
- Makefile.in || die # fix parallel install
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf --host=${CTARGET} || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- local insdir
- is_crosscompile \
- && insdir="${D}/usr/${CTARGET}" \
- || insdir="${D}"
- emake install DESTDIR="${insdir}" || die
- rm -rf "${insdir}"/usr/doc
- dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
- fi
- is_crosscompile && dosym usr /usr/${CTARGET}/mingw
-}