summaryrefslogtreecommitdiff
path: root/dev-util/makepp/makepp-1.50_pre110621.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/makepp/makepp-1.50_pre110621.ebuild')
-rw-r--r--dev-util/makepp/makepp-1.50_pre110621.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/makepp/makepp-1.50_pre110621.ebuild b/dev-util/makepp/makepp-1.50_pre110621.ebuild
new file mode 100644
index 000000000000..d19d34f743bb
--- /dev/null
+++ b/dev-util/makepp/makepp-1.50_pre110621.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils
+
+MY_PV=${PV/_pre/-}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV%_pre*}/${MY_P}.txz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ ln -s "${DISTDIR}/${A}" ${P}.tar.xz
+ unpack ./${P}.tar.xz
+}
+
+src_prepare() {
+# epatch "${FILESDIR}"/${P}-install.patch
+ # remove ones which cause sandbox violations
+# rm makepp_tests/wildcard_repositories.test
+ # default "all" rule is to run tests :x
+ sed -i '/^all:/s:test::' config.pl || die
+}
+
+src_configure() {
+ # not an autoconf configure script
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/makepp \
+ || die "configure failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog README
+}