summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild')
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..ecbde452e97b
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"
+
+# https://bugs.gentoo.org/894468
+# https://github.com/lxqt/lxqt-build-tools/pull/83
+PATCHES=( "${FILESDIR}"/"${PN}"-cpp17-standard.patch )