summaryrefslogtreecommitdiff
path: root/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.11.0.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.11.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
new file mode 100644
index 000000000000..ecc26c91c8ac
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples numa"
+
+DEPEND="
+ dev-libs/userspace-rcu:=
+ numa? ( sys-process/numactl )
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable numa) \
+ --docdir=/usr/share/doc/${PF}
+}