summaryrefslogtreecommitdiff
path: root/dev-util/itstool/itstool-2.0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/itstool/itstool-2.0.6-r1.ebuild')
-rw-r--r--dev-util/itstool/itstool-2.0.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/itstool/itstool-2.0.6-r1.ebuild b/dev-util/itstool/itstool-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..d277093282fd
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are under a special exception || GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+
+src_test() {
+ :
+ #"${PYTHON}" tests/run_tests.py || die "test suite failed" # Test suite not shipped in tarball
+}