summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-system-controller
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest3
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild51
-rw-r--r--dev-util/intel-graphics-system-controller/metadata.xml22
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
new file mode 100644
index 000000000000..56b54315948d
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -0,0 +1,3 @@
+DIST intel-graphics-system-controller-0.2.3.tar.gz 124505 BLAKE2B 50bfaf5dee2fd55d92cd7e544faa8c26930f809b1f4d6dbdc332aec0ace0ced9e21817479c87c4ec12d1117209696b2146c2c6aeb1cfde4ad654d065547e8a6b SHA512 a3ecac36170b0f5c508e077c35336f5c2122d4cc2917e68237af3c92fb82b5f080deee4dded68cb36922cb9edd4d78f7b7a6ed2295649a538ab83ad30c280761
+EBUILD intel-graphics-system-controller-0.2.3.ebuild 1096 BLAKE2B f4cb6fb876fc92b6386fcb1fd2156a156270857e210842b56b47971bf1adb517674fcde0178831865aba34747cd9f094b776e806d9160e004476224c7212fac9 SHA512 1fa4b90b5b15901534c9b2217b7d0d31458352372568bffcb44eefad1932f25825503cff6cba1a45f12d7e9b684b37e9948501791d486d357c438e082bc03d3c
+MISC metadata.xml 673 BLAKE2B 02fb8a2d3c440c4b0082ea695f223e7affd011bd8021a32dd50774373896a672f0b95f164b4f9c0b5fbc16d3bc192097da95324d9220252c3ff3c0dc65280b58 SHA512 647a7e680227c3afbd0b2422039649bd43ceba67cbf0ef8c7053fbae8a6f781247e7903373fc5fb8e25b9623f9f4348de70f8a0184f133fbcf7049c9f28de062
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
new file mode 100644
index 000000000000..632531f54bc9
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_ENUM="ON"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-util/intel-graphics-system-controller/metadata.xml b/dev-util/intel-graphics-system-controller/metadata.xml
new file mode 100644
index 000000000000..dbc97950ff38
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@taujhe.de</email>
+ <name>Jan Henke</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <use>
+ <flag name="cli">Build CLI tools for flashing manually a firmware upgrade.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">intel/igsc</remote-id>
+ </upstream>
+</pkgmetadata>