summaryrefslogtreecommitdiff
path: root/dev-util/indent/indent-2.2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/indent/indent-2.2.13.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.13.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/indent/indent-2.2.13.ebuild b/dev-util/indent/indent-2.2.13.ebuild
new file mode 100644
index 000000000000..1a5bd3be15c1
--- /dev/null
+++ b/dev-util/indent/indent-2.2.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools strip-linguas
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="https://www.gnu.org/software/indent/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+BDEPEND="
+ app-text/texi2html
+ nls? ( sys-devel/gettext )
+"
+DEPEND="nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e '/AM_CFLAGS/s:-Werror::g' src/Makefile.{am,in} || die
+ eautoreconf
+}
+
+src_configure() {
+ strip-linguas -i po/
+
+ export gl_cv_cc_vis_werror=no
+ export ac_cv_func_setlocale=$(usex nls)
+
+ econf $(use_enable nls)
+}
+
+src_test() {
+ emake -C regression
+}