summaryrefslogtreecommitdiff
path: root/dev-util/icmake/icmake-9.03.01.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/icmake/icmake-9.03.01.ebuild')
-rw-r--r--dev-util/icmake/icmake-9.03.01.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/icmake/icmake-9.03.01.ebuild b/dev-util/icmake/icmake-9.03.01.ebuild
index e6bd5c26d8b4..864297a798f1 100644
--- a/dev-util/icmake/icmake-9.03.01.ebuild
+++ b/dev-util/icmake/icmake-9.03.01.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,16 +8,16 @@ inherit toolchain-funcs flag-o-matic
DESCRIPTION="Hybrid between a make utility and a shell scripting language"
HOMEPAGE="https://fbb-git.gitlab.io/icmake/ https://gitlab.com/fbb-git/icmake"
SRC_URI="https://gitlab.com/fbb-git/${PN}/-/archive/${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S=${WORKDIR}/${P}/${PN}
-
PATCHES=(
"${FILESDIR}"/${PN}-9.00.00-ar.patch
"${FILESDIR}"/${PN}-9.02.02-verbose-build.patch
+ "${FILESDIR}"/${PN}-9.03.01-compressed-docs.patch
)
src_prepare() {
@@ -35,11 +35,11 @@ src_prepare() {
}
src_configure() {
- ./icm_prepare "${EROOT}" || die
+ ./icm_prepare "${EPREFIX}" || die
}
src_compile() {
- ./icm_bootstrap "${EROOT}" || die
+ ./icm_bootstrap "${EPREFIX}" || die
}
src_install() {