summaryrefslogtreecommitdiff
path: root/dev-util/howdoi/howdoi-2.0.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/howdoi/howdoi-2.0.17.ebuild')
-rw-r--r--dev-util/howdoi/howdoi-2.0.17.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/howdoi/howdoi-2.0.17.ebuild b/dev-util/howdoi/howdoi-2.0.17.ebuild
new file mode 100644
index 000000000000..a0b3cd960b87
--- /dev/null
+++ b/dev-util/howdoi/howdoi-2.0.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="manual"
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A code search tool"
+HOMEPAGE="https://pypi.org/project/howdoi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cachelib[${PYTHON_USEDEP}]
+ dev-python/keep[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyquery-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+"