summaryrefslogtreecommitdiff
path: root/dev-util/hip/hip-4.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hip/hip-4.1.0-r1.ebuild')
-rw-r--r--dev-util/hip/hip-4.1.0-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-util/hip/hip-4.1.0-r1.ebuild b/dev-util/hip/hip-4.1.0-r1.ebuild
index 827305877f9f..15d5bfcd3e35 100644
--- a/dev-util/hip/hip-4.1.0-r1.ebuild
+++ b/dev-util/hip/hip-4.1.0-r1.ebuild
@@ -59,6 +59,8 @@ src_prepare() {
hprefixify $(grep -rl --exclude-dir=build/ "/usr" "${S}")
cp "$(prefixify_ro "${FILESDIR}"/hipvars.pm)" bin/ || die "failed to replace hipvars.pm"
+ sed -e "s,@HIP_BASE_VERSION_MAJOR@,$(ver_cut 1)," -e "s,@HIP_BASE_VERSION_MINOR@,$(ver_cut 2)," \
+ -e "s,@HIP_VERSION_PATCH@,$(ver_cut 3)," -i bin/hipvars.pm || die
}
src_configure() {