summaryrefslogtreecommitdiff
path: root/dev-util/google-perftools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/Manifest2
-rw-r--r--dev-util/google-perftools/google-perftools-2.4.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 9c1d9b243d43..f69facfbff33 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,5 +1,7 @@
+DIST gperftools-2.4.tar.gz 890402 BLAKE2B f4893d7c9bbd3a8dc5b4d8a25837039261fa32782e13653991002ab666d6e81de637932a8b46c66df219336adcc395a217a4ce32332e8e1558beeb140ea642f2 SHA512 77198c150ee26579adc8f190be0c4ba90a9e3854b006c3aa9252b5863b1fce317fd690c6aa0ed202c81f0bbcfbe2d5f8a182263e77b7fb4fbc6b3e8bfffc9fb0
DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
DIST gperftools-2.7.tar.gz 916919 BLAKE2B c48882df45415110c1ec39298e84ec9384f6a82851d95e92435649d2b253b9fb8e29664b474e45881599abf3781731c47ead0b6c454c33be9a207a6a2401a97c SHA512 9aa39689bc18603123204f024ab6dc96099b70a3d304e31ef0cc1e9893cc77bd14ee6eb420e597d40e81e487a2a45e77cf1965873646d056fd4b7bee22a4b0bb
+EBUILD google-perftools-2.4.ebuild 2294 BLAKE2B 1aaa5d14010c35af89fbe126a6c9d24a2a6921300e273be96868a7254dbedc97e5012ac5d7353e3555b2777268cb299ca576452c7d406234f597d010e6577926 SHA512 8a0d186e63ee7aed584cee1d0897c02eda37b7a0f980a11c715e38513ae684cc0c78675aaf6c8c5ebcfc77da4b1f88f8fc364f38fc856a61ae7365a52f802750
EBUILD google-perftools-2.6.2.ebuild 2313 BLAKE2B 76778b92beab5a0c5c9bcca957551ab891e64dfb47db73eb296fffde41608b9c031e6f20f6d480202865e0776f844bf10b046a2cf4d6d7a656afd05be064245e SHA512 dd7328c32fdf020bfbbd35e074f12b43d7d8fb3cb59aadb430d2c0119be6bb08bb2fd7a22c62314b477aad6edff92e6a42c686d203fd9abceb0e3cd8587073db
EBUILD google-perftools-2.7.ebuild 2353 BLAKE2B 20cf4d3c719658c6172fb116966932cd976fd8d008f0fa50a1a1d1ff4c91050c9d9bdc733fe231189af292ef7a0b53ef6f2c169ae989471533ad68916773a9a9 SHA512 ef93ac049915cb17ac6857b309532c6fb5117ea1bf088d2569bd9cca8b2551102d36d88fa2a5e7eef9541c4e3b8b10804658977a1f5e2cd7f449439ba378c0af
MISC metadata.xml 921 BLAKE2B 71a3db16b3a5a561ee677caf593ff5c45c01bf1cd449da8782e430ffce02b8661c4a011643192f12329ce164ce0148ee206bef85bf55503aae1161067b8e88ca SHA512 e8198e40382ece3675dd43a1878af9cf189d492bc79f246547423b37426981ab2ab624c6d69bc7d57e8a7bdb1f8f4eee32efb1b7d70ecac159dc2a939e480efb
diff --git a/dev-util/google-perftools/google-perftools-2.4.ebuild b/dev-util/google-perftools/google-perftools-2.4.ebuild
new file mode 100644
index 000000000000..da07048b388b
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="gperftools-${PV}"
+inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux x86/amd64/ppc/ppc64/arm
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="largepages +debug minimal optimisememory test static-libs"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS="doc"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug debugalloc) \
+ $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}