summaryrefslogtreecommitdiff
path: root/dev-util/gertty/gertty-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gertty/gertty-1.3.2.ebuild')
-rw-r--r--dev-util/gertty/gertty-1.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/gertty/gertty-1.3.2.ebuild b/dev-util/gertty/gertty-1.3.2.ebuild
new file mode 100644
index 000000000000..e05867388195
--- /dev/null
+++ b/dev-util/gertty/gertty-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
+HOMEPAGE="https://pypi.python.org/pypi/gertty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/git-python-0.3.2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ dev-python/ordereddict[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"