summaryrefslogtreecommitdiff
path: root/dev-util/gcovr/gcovr-6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gcovr/gcovr-6.0.ebuild')
-rw-r--r--dev-util/gcovr/gcovr-6.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/gcovr/gcovr-6.0.ebuild b/dev-util/gcovr/gcovr-6.0.ebuild
new file mode 100644
index 000000000000..f721625bc8ed
--- /dev/null
+++ b/dev-util/gcovr/gcovr-6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python script for summarizing gcov data"
+HOMEPAGE="https://github.com/gcovr/gcovr"
+SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/yaxmldiff[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib"
+
+ local deselect=(
+ # those tests fail on gcc newer than 5.8
+ # https://github.com/gcovr/gcovr/issues/206
+ gcovr/tests/test_gcovr.py
+ )
+
+ epytest gcovr ${deselect[@]/#/--deselect }
+}