summaryrefslogtreecommitdiff
path: root/dev-util/ftjam/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ftjam/files')
-rw-r--r--dev-util/ftjam/files/ftjam-2.5.3-debug-commandline.patch14
-rw-r--r--dev-util/ftjam/files/ftjam-2.5.3-false-flags.patch59
-rw-r--r--dev-util/ftjam/files/ftjam-2.5.3-i-hate-yacc.patch54
-rw-r--r--dev-util/ftjam/files/ftjam-2.5.3-nostrip.patch40
4 files changed, 167 insertions, 0 deletions
diff --git a/dev-util/ftjam/files/ftjam-2.5.3-debug-commandline.patch b/dev-util/ftjam/files/ftjam-2.5.3-debug-commandline.patch
new file mode 100644
index 000000000000..ba6613430308
--- /dev/null
+++ b/dev-util/ftjam/files/ftjam-2.5.3-debug-commandline.patch
@@ -0,0 +1,14 @@
+Make jam print the commandline it's executing.
+Only useful for ebuild debugging - I just always forget how to enable it.
+
+--- ftjam-2.5.3rc2-orig/builds/unix/Makefile.in
++++ ftjam-2.5.3rc2/builds/unix/Makefile.in
+@@ -16,7 +16,7 @@
+
+ all: jam0
+ chmod a+w jambase.c
+- ./jam0
++ ./jam0 -dx -q
+
+ include common.mk
+
diff --git a/dev-util/ftjam/files/ftjam-2.5.3-false-flags.patch b/dev-util/ftjam/files/ftjam-2.5.3-false-flags.patch
new file mode 100644
index 000000000000..1b33a0f770d3
--- /dev/null
+++ b/dev-util/ftjam/files/ftjam-2.5.3-false-flags.patch
@@ -0,0 +1,59 @@
+Respect CC, *FLAGS. Add datarootdir for autoconf-2.60 warnings.
+
+--- ftjam-2.5.3rc2-orig/builds/unix/Makefile.in
++++ ftjam-2.5.3rc2/builds/unix/Makefile.in
+@@ -37,6 +37,7 @@ exec_prefix := @exec_prefix@
+ libdir := @libdir@
+ bindir := @bindir@
+ includedir := @includedir@
++datarootdir := @datarootdir@
+ datadir := @datadir@
+
+ version_info := @version_info@
+--- ftjam-2.5.3rc2-orig/jambase.c
++++ ftjam-2.5.3rc2/jambase.c
+@@ -652,21 +652,21 @@ const char *jambase[] = {
+ "\n",
+ "AR ?= ar ru ;\n",
+ "AS ?= as ;\n",
+-"ASFLAGS ?= ;\n",
++"ASFLAGS += $(ASFLAGS) ;\n",
+ "AWK ?= awk ;\n",
+ "BINDIR ?= /usr/local/bin ;\n",
+-"C++ ?= cc ;\n",
+-"C++FLAGS ?= ;\n",
+-"CC ?= cc ;\n",
+-"CCFLAGS ?= ;\n",
++"C++ ?= $(CXX) ;\n",
++"C++FLAGS += $(CXXFLAGS) ;\n",
++"CC ?= $(CC) ;\n",
++"CCFLAGS += $(CFLAGS) ;\n",
+ "CP ?= cp -f ;\n",
+ "CRELIB ?= ;\n",
+ "DOT ?= . ;\n",
+ "DOTDOT ?= .. ;\n",
+ "EXEMODE ?= 711 ;\n",
+ "FILEMODE ?= 644 ;\n",
+-"FORTRAN ?= f77 ;\n",
+-"FORTRANFLAGS ?= ;\n",
++"FORTRAN ?= $(F77) ;\n",
++"FORTRANFLAGS += $(FFLAGS) ;\n",
+ "HDRS ?= ;\n",
+ "INSTALLGRIST ?= installed ;\n",
+ "JAMFILE ?= Jamfile ;\n",
+@@ -674,13 +674,13 @@ const char *jambase[] = {
+ "LEX ?= ;\n",
+ "LIBDIR ?= /usr/local/lib ;\n",
+ "LINK ?= $(CC) ;\n",
+-"LINKFLAGS ?= ;\n",
++"LINKFLAGS += $(LDFLAGS) ;\n",
+ "LINKLIBS ?= ;\n",
+ "LN ?= ln ;\n",
+ "MANDIR ?= /usr/local/man ;\n",
+ "MKDIR ?= mkdir ;\n",
+ "MV ?= mv -f ;\n",
+-"OPTIM ?= ;\n",
++"OPTIM = ;\n",
+ "RCP ?= rcp ;\n",
+ "RM ?= rm -f ;\n",
+ "RMDIR ?= $(RM) ;\n",
diff --git a/dev-util/ftjam/files/ftjam-2.5.3-i-hate-yacc.patch b/dev-util/ftjam/files/ftjam-2.5.3-i-hate-yacc.patch
new file mode 100644
index 000000000000..44322d64c2cf
--- /dev/null
+++ b/dev-util/ftjam/files/ftjam-2.5.3-i-hate-yacc.patch
@@ -0,0 +1,54 @@
+diff -Naurp ftjam-2.5.3rc2-orig/Jambase ftjam-2.5.3rc2/Jambase
+--- ftjam-2.5.3rc2-orig/Jambase 2007-06-05 08:20:19.000000000 -0600
++++ ftjam-2.5.3rc2/Jambase 2008-07-21 19:26:02.000000000 -0600
+@@ -813,7 +813,7 @@ else if $(UNIX)
+ LINKLIBS ?= ;
+ OPTIM ?= -O ;
+ RANLIB ?= ranlib ;
+- YACC ?= yacc ;
++ YACC ?= bison -y ;
+ YACCGEN ?= .c ;
+ YACCFILES ?= y.tab ;
+ YACCFLAGS ?= -d ;
+@@ -882,10 +882,10 @@ DC ?= dmd ;
+ SUFLIB ?= .a ;
+ SUFOBJ ?= .o ;
+ UNDEFFLAG ?= "-u _" ;
+- YACC ?= ;
+- YACCGEN ?= ;
+- YACCFILES ?= ;
+- YACCFLAGS ?= ;
++ YACC ?= bison -y ;
++ YACCGEN ?= .c ;
++ YACCFILES ?= y.tab ;
++ YACCFLAGS ?= -d ;
+
+ HDRPATTERN =
+ "^[ ]*#[ ]*include[ ]*[<\"]([^\">]*)[\">].*$" ;
+diff -Naurp ftjam-2.5.3rc2-orig/jambase.c ftjam-2.5.3rc2/jambase.c
+--- ftjam-2.5.3rc2-orig/jambase.c 2007-06-05 08:31:08.000000000 -0600
++++ ftjam-2.5.3rc2/jambase.c 2008-07-21 19:27:55.000000000 -0600
+@@ -632,7 +632,7 @@ const char *jambase[] = {
+ "LINKLIBS ?= ;\n",
+ "OPTIM ?= -O ;\n",
+ "RANLIB ?= ranlib ;\n",
+-"YACC ?= yacc ;\n",
++"YACC ?= bison -y ;\n",
+ "YACCGEN ?= .c ;\n",
+ "YACCFILES ?= y.tab ;\n",
+ "YACCFLAGS ?= -d ;\n",
+@@ -695,10 +695,10 @@ const char *jambase[] = {
+ "SUFLIB ?= .a ;\n",
+ "SUFOBJ ?= .o ;\n",
+ "UNDEFFLAG ?= \"-u _\" ;\n",
+-"YACC ?= ;\n",
+-"YACCGEN ?= ;\n",
+-"YACCFILES ?= ;\n",
+-"YACCFLAGS ?= ;\n",
++"YACC ?= bison -y ;\n",
++"YACCGEN ?= .c ;\n",
++"YACCFILES ?= y.tab ;\n",
++"YACCFLAGS ?= -d ;\n",
+ "\n",
+ "HDRPATTERN =\n",
+ "\"^[ ]*#[ ]*include[ ]*[<\\\"]([^\\\">]*)[\\\">].*$\" ;\n",
diff --git a/dev-util/ftjam/files/ftjam-2.5.3-nostrip.patch b/dev-util/ftjam/files/ftjam-2.5.3-nostrip.patch
new file mode 100644
index 000000000000..1b7e69fc2c8f
--- /dev/null
+++ b/dev-util/ftjam/files/ftjam-2.5.3-nostrip.patch
@@ -0,0 +1,40 @@
+diff -Naur ftjam-2.5.3rc2-orig/Jamfile ftjam-2.5.3rc2/Jamfile
+--- ftjam-2.5.3rc2-orig/Jamfile 2007-06-05 08:30:52.000000000 -0600
++++ ftjam-2.5.3rc2/Jamfile 2007-06-10 12:55:03.000000000 -0600
+@@ -138,16 +138,6 @@
+ LinkLibraries jam : libjam.a ;
+ GenFile jambase.c : mkjambase Jambase ;
+
+-if $(UNIX) && ! $(DEBUG)
+-{
+- actions Strip
+- {
+- strip $(1)
+- }
+-
+- Strip jam ;
+-}
+-
+ Library libjam.a :
+ builtins.c command.c compile.c $(code) expand.c
+ glob.c hash.c headers.c lists.c make.c make1.c
+@@ -156,19 +146,6 @@
+ hdrmacro.c rope.c
+ ;
+
+-# Strip the Jam executable on Mingw
+-#
+-if $(JAM_TOOLSET) = MINGW
+-{
+- actions Strip
+- {
+- strip $(1)
+- }
+-
+- Strip jam$(SUFEXE) ;
+-}
+-
+-
+ if $(BINDIR) { InstallBin $(BINDIR) : jam ; }
+
+ #