summaryrefslogtreecommitdiff
path: root/dev-util/flawfinder/flawfinder-2.0.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/flawfinder/flawfinder-2.0.18.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.18.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-2.0.18.ebuild b/dev-util/flawfinder/flawfinder-2.0.18.ebuild
new file mode 100644
index 000000000000..b4b8332321bf
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.18.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+src_prepare() {
+ sed -e "s/${PN}.1.gz/${PN}.1/g" -i setup.py || die 'sed failed'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}