summaryrefslogtreecommitdiff
path: root/dev-util/flawfinder/flawfinder-1.31.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/flawfinder/flawfinder-1.31.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-1.31.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-1.31.ebuild b/dev-util/flawfinder/flawfinder-1.31.ebuild
new file mode 100644
index 000000000000..6ef0a76bccb4
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-1.31.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="https://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc announcement ChangeLog README announcement
+ dodoc flawfinder.pdf
+ python_fix_shebang "${ED}"usr/bin/flawfinder
+}