summaryrefslogtreecommitdiff
path: root/dev-util/fhist/fhist-1.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/fhist/fhist-1.19.ebuild')
-rw-r--r--dev-util/fhist/fhist-1.19.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/fhist/fhist-1.19.ebuild b/dev-util/fhist/fhist-1.19.ebuild
new file mode 100644
index 000000000000..c23d28e436b5
--- /dev/null
+++ b/dev-util/fhist/fhist-1.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+src_prepare() {
+ MAKEOPTS+=" -j1"
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ append-cflags -fgnu89-inline
+}