summaryrefslogtreecommitdiff
path: root/dev-util/dwarves/dwarves-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dwarves/dwarves-9999.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/dwarves/dwarves-9999.ebuild b/dev-util/dwarves/dwarves-9999.ebuild
index 75a15ff54a89..f9e4f9feeb3b 100644
--- a/dev-util/dwarves/dwarves-9999.ebuild
+++ b/dev-util/dwarves/dwarves-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,13 +18,16 @@ IUSE="debug"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- >=dev-libs/elfutils-0.131
- <=dev-libs/elfutils-0.177
+ >=dev-libs/elfutils-0.178
sys-libs/zlib"
DEPEND="${RDEPEND}"
DOCS=( README README.ctracer NEWS )
-PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+ "${FILESDIR}"/${PN}-1.16-no-libebl.patch
+)
src_configure() {
local mycmakeargs=( "-D__LIB=$(get_libdir)" )